Flickr APIのURLが変更になった。

Flickr APIを使ってるんだけど、いつの間にかエラーが出るようになっていた。
以下のエラーコード95が返ってくる。

<rsp stat=”fail”>
<err code=”95″ msg=”SSL is required”/>
</rsp>

海外のサイトを見ると、APIのリクエストURLが変更になったとのこと。

https://www.flickr.com/help/forum/en-us/72157645440333073/

Today’s the Day!

(Disclaimer, this post is probably only interesting to API developers)

It’s the day you’ve been preparing for, as of 10:00 PST this morning we will be switching the Flickr API to https-only access. We’ve had two blackouts, emailed all API key owners, and posted a bunch of info over on the code blog, so hopefully you’re ready.

とのことで、リクエストするときのURLを

http

https

へ変更しないと使えなくなっている。フリッカーのAPIのオーナーには全員メールをしたと書いてあるが、全く気づかなかった。。。


広告

コメントを残す