phpのバージョンアップ関連で出るエラー

手元のパソコンで使う用のPHPで自作したツールがいくつかあるんだけど、新しいパソコンにプログラムを移してPHPの環境作ったらエラーが頻発。
phpのバージョンが新しくなったことによるエラーだった。

Notice: Trying to get property of non-object in ~

のエラーが一番多かった。上のエラーで検索すると、エラーが画面表示されてるサイトがたくさん出てくる。自動的にPHPのバージョンがあがるサーバーなどだと、エラー出てもそのまま放置されてるサイトが多いみたい。上のエラーは何かの処理がバージョンアップに伴い、厳密に処理されることによる発生するようになったらしい。私の場合はエラーが出ても機能自体はすべて問題なく動いてる。でもエラー表示が邪魔なんで、結論だけ書くと、エラーが出てる行の前に@をつけてエラー表示しないようにするととりあえずすべて解決(ほんとはエラーでないように書きなおす方がいいんだろうけど)。他にもいくつかバージョンアップに伴うエラー表示があったけど、全部@を付けるだけで解決した。


広告

コメントを残す